summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
authorattilamolnar <attilamolnar@hush.com>2013-06-11 00:33:31 +0200
committerattilamolnar <attilamolnar@hush.com>2013-06-11 00:33:31 +0200
commitabe675bfac8b2e975ceec396139f54fb32ad0917 (patch)
treed7bcb73ef9a97cdb76e863872a595b87ea0f22a4 /win/CMakeLists.txt
parent9a470c5863f796308c8761457cd3e66b8f836380 (diff)
Build with multiple processes on Windows (/MP)
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index ca7e9eb18..a9c58bcfc 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -12,6 +12,9 @@ set(EXTRA_LIBS "" CACHE PATH "Extra library paths")
set(INSPIRCD_BASE "${CMAKE_CURRENT_SOURCE_DIR}/../")
+# Build with multiple processes
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /MP")
+
# Use our own NSIS template
set(CMAKE_MODULE_PATH "${INSPIRCD_BASE}/win")