summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam <Adam@anope.org>2017-05-09 18:37:23 -0400
committerAdam <Adam@anope.org>2017-05-09 18:37:23 -0400
commit1daaf3b84d87e543ee43c2f8b9b3cd0a02787424 (patch)
treef1f1d1961a9151824104873995d34cdc8cc1e2b8 /win/CMakeLists.txt
parent879c1988fea364c9ccdf529599e3bd06615bc3e7 (diff)
win: set CMAKE_INSTALL_SYSTEM_RUNTIME_DESTINATION to . so the runtime libraries are not placed in bin
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index 10653cf74..7be08a3fc 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -85,6 +85,7 @@ file(MAKE_DIRECTORY ${LOG_PATH})
install(DIRECTORY ${LOG_PATH} DESTINATION .)
if(EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
+ set(CMAKE_INSTALL_SYSTEM_RUNTIME_DESTINATION ".") # place runtime libraries next to InspIRCd binary
include(InstallRequiredSystemLibraries)
set(CPACK_PACKAGE_NAME "InspIRCd IRC Daemon")