summaryrefslogtreecommitdiff
path: root/win/CMakeLists.txt
diff options
context:
space:
mode:
authorAttila Molnar <attilamolnar@hush.com>2016-02-22 12:52:18 +0100
committerAttila Molnar <attilamolnar@hush.com>2016-02-22 12:52:18 +0100
commit0b63ccd0b5cb26883d6becb196fb98e4f95d0397 (patch)
treed9c660b46e106d76c5953579eca45e49c4486cbf /win/CMakeLists.txt
parent7b6bd133ca4472f6cb8058d5e34e3c8b2af7e99a (diff)
parent1624ab03b86542a2cb02eda809303144974755f3 (diff)
Merge insp20
Diffstat (limited to 'win/CMakeLists.txt')
-rw-r--r--win/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/win/CMakeLists.txt b/win/CMakeLists.txt
index 3cfe9f6b8..768270696 100644
--- a/win/CMakeLists.txt
+++ b/win/CMakeLists.txt
@@ -78,6 +78,10 @@ install(FILES ${EXTRA_DLLS} DESTINATION .)
file(GLOB_RECURSE EXAMPLE_CONFIGS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${INSPIRCD_BASE}/docs/conf/*.example")
install(FILES ${EXAMPLE_CONFIGS} DESTINATION conf)
+# Install nationalchars files
+file(GLOB_RECURSE EXAMPLE_LOCALES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "${INSPIRCD_BASE}/locales/*")
+install(FILES ${EXAMPLE_LOCALES} DESTINATION locales)
+
# Create an empty data and logs directory and install them
file(MAKE_DIRECTORY ${DATA_DIR})
install(DIRECTORY ${DATA_DIR} DESTINATION .)