summaryrefslogtreecommitdiff
path: root/test/configure.ac
diff options
context:
space:
mode:
authorPhilip Hazel <ph10@hermes.cam.ac.uk>2006-02-06 16:07:10 +0000
committerPhilip Hazel <ph10@hermes.cam.ac.uk>2006-02-06 16:07:10 +0000
commit151b83f867487080e8f0e5cd6179e857dc6b3ccb (patch)
treedbcf00f18c4854a6c30e22b1a390ea842d7e5b38 /test/configure.ac
parent309bd837529724b7574e2b0b7bdaf1a271137199 (diff)
CVS-ing the new test suite.
Diffstat (limited to 'test/configure.ac')
-rw-r--r--test/configure.ac54
1 files changed, 54 insertions, 0 deletions
diff --git a/test/configure.ac b/test/configure.ac
new file mode 100644
index 000000000..8b318034d
--- /dev/null
+++ b/test/configure.ac
@@ -0,0 +1,54 @@
+dnl $Cambridge: exim/test/configure.ac,v 1.1 2006/02/06 16:07:10 ph10 Exp $
+
+dnl Process this file with autoconf to produce a configure script.
+
+dnl This is required at the start; the name is the name of a file
+dnl it should be seeing, to verify it is in the same directory.
+
+AC_INIT(listtests)
+
+dnl A safety precaution
+
+AC_PREREQ(2.57)
+
+dnl Checks for programs.
+
+AC_PROG_CC
+
+dnl Checks for header files.
+
+AC_CHECK_HEADERS(openssl/crypto.h,[CLIENT_SSL=bin/client-ssl])
+AC_CHECK_HEADERS(gnutls/gnutls.h,[CLIENT_GNUTLS=bin/client-gnutls])
+
+dnl The check on dynamically loaded modules requires the building of
+dnl something to load. This seems to be something that varies between
+dnl systems and compilers something awful. Therefore, we enable it only
+dnl for those systems and compilers that we know about.
+
+dnl I tried using AC_CANONICAL_HOST, but it insisted on looking for an
+dnl "install" script for some weird reason.
+
+host_os=`uname -s`
+
+case $CC-$host_os in
+ gcc-*linux* | gcc-*Linux* | gcc-*LINUX* | gcc-FreeBSD)
+ LOADED=bin/loaded
+ LOADED_OPT=-shared
+ echo "Using gcc on $host_os: will compile dynamically loaded module"
+ ;;
+ *)
+ LOADED=
+ echo "Will not compile dynamically loaded module: not known OS/CC combination"
+ ;;
+esac
+
+dnl "Export" these variables
+
+AC_SUBST(CLIENT_SSL)
+AC_SUBST(CLIENT_GNUTLS)
+AC_SUBST(LOADED)
+AC_SUBST(LOADED_OPT)
+
+dnl This must be last; it determines what files are written
+
+AC_OUTPUT(Makefile)